Jump to content

Search the Community

Showing results for tags 'KMS'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Blogs

  • Alexander72's Blog
  • SteveD's Blog
  • Norman's Blog
  • Marto's Blog
  • Soot1e's Blog
  • Dommo's Blog
  • KugaWestie's Blog
  • R7 WSC's Blog
  • shindha's Blog
  • Nothing ventured nothing gained
  • Mark's First Time Build Blog
  • marcusb's Blog
  • Meakin's Blog
  • pickmaster's Blog engine swap
  • Steve_Farrimond's Blog
  • PaulJones148's Blog
  • paul gibney's Blog
  • philwilson133's Blog
  • Koso Digital Dash Fitting
  • IanG1's Blog
  • Tel's Tales
  • chrisando's Blog
  • Pistol Pete - Essex AO x 0.5's Blog
  • Enclosed Trailer Build Diary
  • Piece of cake
  • johnbmaximus' Blog
  • harry may 11's Blog
  • johngill's Blog
  • waynezilla's Blog
  • Fishcake's Blog
  • Julian's 7se rebuild
  • japltor60's Blog
  • Xflow17's Blog
  • How to Assemble a Duratec
  • Beez's 2014 Sprint Blog
  • czphillips' Sigma Swap
  • West300's Blog
  • Speed Series Results
  • Wagoneer's Blog
  • First Westi
  • Quinten's Mighty Blog
  • Chriscooper1's Blog
  • Murraymint's Blog
  • johnev's Blog
  • Master Thatcher's Blog
  • Chris Hooper's SDV Mazda build.
  • Mr T's Blog
  • Nosbod's Mega S2000 Blog
  • stephenh's Blog
  • TREVORGIDLOW's Blog
  • AdamR's MX-R1000 Build
  • My Lawnmower Runs on Super...
  • johnev's Blog
  • John's Sport 250 Build
  • Jaguar C Type
  • Andy665's SEiGHT
  • Loton Park 2017
  • Toys4x4boys Westy Journey
  • Sprinting (not the Usain Bolt type)
  • Rob
  • A Seven Tour(s)
  • Bills Birthday
  • Raising the dead

Forums

  • Main Club Area
    • The Start Line
    • Frequently Asked Questions (FAQs)
    • Tech Talk
    • IVA Info
    • X-Cars
    • Membership Information ONLY
  • Out & About With Your Westfield
    • Local Area Meets, Events & Kit Car Shows
    • Speed Series / Hill Climbing / Racing
    • Track Days
    • Places to Visit and Road Trips
  • Club Member Adverts
    • Cars for Sale
    • Cars Wanted
    • Parts for Sale
    • Parts Wanted
  • External and Non-Club Member Adverts
    • External Adverts
  • Chat & General Information
    • Stuff & Nonsense

Calendars

  • Speed Series Events Calendar
  • WSCC Local Events Calendar
  • WSCC Events Calendar

Product Groups

  • WSCC Membership
  • WSCC Speed Series
  • WSCC Track Days
  • Admin Only (No Products)
    • Previous Sprint Events
    • Previous Track Days
    • Previous Merchandise
    • Previous Club Publications
  • Club Publications

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 2 results

  1. Last week I bought a Westfield with a 2.0 Duratec engine. This car was factory build in 2009. The previous owner barely drove it and currenlty it has 14300 km (8885 miles) and always stored it inside. So I can say that it's an almost new car. But I have the feeling that it is running way too rich: I have a very high fuel consumption, the car easily stalls and when I'm driving it doesn't feel like a 2.0 Duratec. There is also a lot of backfire in the exhaust, even in the lower rpm-band 2000-3500 I searched here on the forum and it seems that I'm not the only one with this problem: http://forum.wscc.co.uk/forum/index.php/topic/75321-duratec-owners/ http://forum.wscc.co.uk/forum/index.php/topic/86191-anyone-with-kms-duratec/ OP's of the above topics also have a KMS ecu which was mapped in the Westfield factory and our cars are from the same period (2008-2010). There is nothing wrong with KMS. Those are solid ecu's but I think something went wrong with the map. Here are a few pictures: I removed the sparks; Current brand is Champion S9YCC but I'm going to replace them with Autolite XP104 As you can see, sparks are very back/oily. I also found the location of the ECU (above the passenger's feet) It's a KMS MP25 http://kms.vankronenburg.nl/nl/producten/kms-ecus/mp25-management-ecu/ I was already able to connect my laptop with the ecu and download the map. The software can be donwloaded for free from the manufacturer's website. On the left of the ecu there is serial connection (you can hardly see it on the picture) and with a serial to USB cable I was able to make a connection. Gonna take a look at the map. I'm not an expert so I don't know if I can see something. I'm def. not going to change anything
  2. Hello All, I'm David, I live in Belgium and since last week I have a Westfield with a 2.0 Ford Duratec engine and KMS ecu. The car was factory assembled in 2009 and I'm the 2nd owner. The previous owner turned 75 and it became too difficult for him to get in/out of the car. So he decided to sell it. He now has a Morgan Aero. I think that's an acceptable replacement The previous owner barely drove it, at the moment the car has 14300km (8886 miles) and always stored it inside. So I can say it's a barely new car. But at the moment I'm not happy about the Duratec engine: It seems that the car runs much too rich. I have exactly the same as these guys had, It seems that a few (or most?) Duratecs from around 2009-2011 left the factory without a decent map: (I'll open a separate topic about that shortly) http://forum.wscc.co.uk/forum/index.php/topic/86191-anyone-with-kms-duratec/ http://forum.wscc.co.uk/forum/index.php/topic/75321-duratec-owners/ I added some pictures but I don't like them very much because it was rainy. Will post more and better pictures on a sunny day... hopefully soon. And hopefully soon also happy about the Duratec
×
×
  • Create New...

Important Information

Please review our Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.