Jump to content

Recommended Posts

Hello all, 

Wanted to reach people with experience in these ecus as i lack both experience and reading material to start working on it.
 

The ecu and loom was previously on a Vauxhall 2.0l

4 cylinder 4 injector engine.

 

Now the MBE 977 is on a restored Mini Metro 1.3 that i'll be posting photos later on.


First big difference as its a new platform for the ecu.

 

This 1.3 is a 4 cylinder 2 injector engine.


On my first try i could not read anything from the ecu.
After an hour of checking what could be wrong i had luck connecting to the ecu with the oem cable from MBE, but .. for some strange reason only when i kept pressing on the accelerator pedal.

Leave the accelerator...and  ecu connection is lost.

 

In that state with pressed acc pedal i tried to download the previous tune to the hdd.

progress kept going over 100% (see photo)

 

So as things are becoming a bit like xfiles from the start of it with no literature.

 

I ask for anyhelp (pdfs , books, schematics, reading material on this ecu or genre) or even a remote help via anydesk etc paid if need be of course.

 

I am not a tuner, i am an enthousiast learning and wont tune the car alone . I want to reach the point of at least a startup before getting it tuned by a proffesional on a rr.

 

Maybe its beyond my level but i am willing to work on it. Let me hear your thoughts and i will provide any extra info you need. 

 

thank you for reading

IMG_20210216_184844.jpg

file1.jpg

file2.jpg

Edited by Stergios
tags
Link to post
Share on other sites
Chris King

I found the software was sensitive to the “baud rate” setting in the USB adapter config. 
 

It’s been several years since I had an MBE so can’t recall the settings - but worth googling it perhaps?

  • Like 1
Link to post
Share on other sites
2 hours ago, Chris King said:

I found the software was sensitive to the “baud rate” setting in the USB adapter config. 
 

It’s been several years since I had an MBE so can’t recall the settings - but worth googling it perhaps?

It's connecting serial com port at 19200 baud. 
Trouble is it does that only with accelerator pedal pressed!
 

 

2 hours ago, Trevturtle said:

It may be worth contacting Ian Oddie , Ian's very good

 

No mention of a 977 on Ian's page (below), but he may be able to help with tips on a 977.

 

https://oddified.com/mbe912.php

 

I've send a message through their contact page. thank you

Anyone has a user manual any guide for these ecus at all?

Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary
7 minutes ago, Stergios said:

Anyone has a user manual any guide for these ecus at all?

 

There is none I'm afraid, that I've ever found, generally, with MBE, they were never really that sort of ecu. 

Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary

SBD are the distributor for retail sales of the ecu, they have the nearest to documentation  on them that I've ever come across, but even then it's not a lot.

 

I can't find any info on your model at all, so far, it's not one I've ever come across before.

 

Needing a foot on the accelerator definitely isn't right though!

 

Can you confirm you're using a modified "MBE style comms lead? it should have a few mods over standard RS232 leads.

 

Mapping_Lead_Picture-1024x725.gif

  • Like 1
Link to post
Share on other sites

Yes the cable i am using is the oem one made just like that.
Problem is i get connection to the ecu only with the accelerator pedal pressed. thats why i'm looking for an ecu wiring schematic

I've tried contacting SBD  also no answer so far its been a few days. 
i'll wait a few more no rush 

Link to post
Share on other sites
Trevturtle
14 hours ago, Stergios said:

Anyone has a user manual any guide for these ecus at all?

Easimap 5 manualEasimap 5 manual.pdf .

It should help, but there's a lot to read.

In practice 99% of the time you only need to know how to

  • connect to the ECU
  • edit settings
  • copy the map to your PC

There's much more but I only use the above most of the time

  • Thanks 1
Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary

Good find Trev!

Link to post
Share on other sites
Stergios

An update , Mr, Ian responded promptly and supplied some information. The same that where posted here in part from Chris King and Trevturtle. Thank you guys for that.

First chance i  get the wiring will be checked and hopefully the communication with the ecu will be fix so Ian's instruction on how to move on are applied.

Will come back with pics of the build and an update as soos as i have something more.

 

Many thanks you are a great group of people.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Please review our Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.