Jump to content
Steve (sdh2903)

Aim mxs info thread

Recommended Posts

tc3nitro
37 minutes ago, Steve (sdh2903) said:

@tc3nitro is that a Westfield supplied kit your using or have you bought separately?

 

If I PM you my email address could you ping it to me too?

My kit was supplied direct from AIM, at the time Westfield were not buying the new Strada 1.2 and I wanted this unit. I purchased mine as a kit with the VIM and remote button kit - although I sent the button kit back.

 

Couple of notes though - I could not get my Strada 1.2 to connect to my OMEX 600 ecu ( the ecu was returned to Omex to have the serial telemetry enabled) and you will need to buy a oil pressure sensor ( I bought one from AIM ) these sensor actually perform the task you need unlike the item supplied from westfield (by the time this lights anything up your engine will be dead).

 

Regards

Share this post


Link to post
Share on other sites
Steve (sdh2903)

Cheers for the info. I'm not using a vim which may make things a bit different.

 

Sent an email off to aim to what's what with the displays. I'll be a bit miffed if not available as all of the pics on the site are of the screen I want.

Share this post


Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary
14 minutes ago, Steve (sdh2903) said:

Cheers for the info. I'm not using a vim which may make things a bit different.

 

Sent an email off to aim to what's what with the displays. I'll be a bit miffed if not available as all of the pics on the site are of the screen I want.

 

Be interested to hear the result, as it was a disappointment to me, too. It's no deal breaker, but one of the side effects of going for the bigger display, was loosing the room to put the previous external warning lights back in. So being able to do it with the virtual warning lights on a regular twin dial speedo and tacho page is what helped sell the idea of the MXP. 

 

I have noticed though, that depending on which AiM site you visit, the mocked up screen shots of those pages seem to be being removed and replaced.

Share this post


Link to post
Share on other sites
Steve (sdh2903)

Agreed Dave. Ill update with what they say.

Share this post


Link to post
Share on other sites
Steve (sdh2903)

You were right dave.😡

 

"You can only get the icon display line at the bottom on the one display option at the moment see attached

But we are going to be releasing some new ones soon like the one you have shown me"

 

very dissapointing as yet again Aim shoot themselves in the foot. I've replied asking why on every single Aim site shows the page I want along with a statement of being "fully configurable" when clearly untrue, funny enough they've gone all quiet. Looks like yet another dashboard reconfig is needed as I much prefer the 2 analogue dial page.

Share this post


Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary

A disclaimer appeared on most of the sites I looked at earlier in the year regarding images.

 

When I bought mine, it was worse still, as the "artists impressions" ie mockups, were also showing left and right indicator warning lamps on the upper left and right corners, either side of the shift lights. Again, one of the elements that really sold it. That was the first of the pictures to get taken down.

Share this post


Link to post
Share on other sites
Chris King - Webmaster and Joint North East AO
1 hour ago, Steve (sdh2903) said:

much prefer the 2 analogue dial page

Which isn’t as good in reality as it appears. I tried that one and ditched it as it was not really useable with the dials being too small to read the figures displayed around the perimeter. 

Share this post


Link to post
Share on other sites
Plays-Kool
1 hour ago, Dave Eastwood (Gadgetman) - Club Secretary said:

When I bought mine, it was worse still, as the "artists impressions" ie mockups, were also showing left and right indicator warning lamps on the upper left and right corners, either side of the shift lights. Again, one of the elements that really sold it. That was the first of the pictures to get taken down.

That was down to me as I asked where were the connections to wire these up, as they were so prominently on display in their pictures! 

  • Thanks 1

Share this post


Link to post
Share on other sites
Dave Eastwood (Gadgetman) - Club Secretary

Ah, good call Luke!

Share this post


Link to post
Share on other sites
tc3nitro

All I would say about AIM Uk is don’t believe a thing they promise and don’t rely on them for support or advice as they will just blame you or other companies.

Unless you are spending £00000’s on motorsport products they could give a S***.

 

Share this post


Link to post
Share on other sites
BugMan
13 hours ago, tc3nitro said:

All I would say about AIM Uk is don’t believe a thing they promise and don’t rely on them for support or advice as they will just blame you or other companies.

Unless you are spending £00000’s on motorsport products they could give a S***.

 

Slightly bitter Mark?

Share this post


Link to post
Share on other sites
tc3nitro

Can you tell ?

  • Haha 1

Share this post


Link to post
Share on other sites
BugMan

Just done a firmware up-date, seemed like some fixes, nothing major.

But this got me thinking about the Gear Indicator function, which I have never had work, so here is a plea for any info or working configs, particually if using the Strada on the Sport 250.

Mine has never worked, but this is the current settings

 

GearIndicator.jpg.53343595412983b6fbe4975d55b63f48.jpg

 

Share this post


Link to post
Share on other sites
Chris King - Webmaster and Joint North East AO

From memory mine looks similar except I have 1 sec for shift time as I’m not fast enough to shift at light speed 😁

Share this post


Link to post
Share on other sites
onslack
On 17/06/2019 at 20:51, tc3nitro said:

All I would say about AIM Uk is don’t believe a thing they promise and don’t rely on them for support or advice as they will just blame you or other companies.

Unless you are spending £00000’s on motorsport products they could give a S***.

 

Got to say i fully agree here.

 

They messed my mileage reading up with after a firmware update, took near on 6 months for them to acknowledge that I existed to sort the issue.

 

They did blame me at first, then they said i needed to send my dash back as it was something in the way they they add the mileage to the dash was left open.

 

Few days later a new firmware version came out and like magic my issue was resolved!!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please review our Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.