Jump to content
Steve (sdh2903)

Aim mxs info thread

Recommended Posts

Steve (sdh2903)

As suggested by Chris thought it would be worthwhile to start a thread for those using the AIM MXS dashboard as there's a few of us starting to use them.

Now if you buy the dash from westfield then you shouldn't have any problems as they supply a premade loom to connect between car and dash.

Firstly fuel level.

This has been the hardest thing to configure. In my trials and tribulations I've found you CANT use the westfield harness connections. You have to run 2 direct cables from the dash to the sender. 

You are supposed to be able to input the ohms in racestudio and it will suggest a pull up resistor value and you then create the sensor. However I couldn't get this to work either.

So you need to wire like below. But use a 2.7kohm resistor instead of the 1k shown. Take the earth back to the analogue ground on the dash rather than earthing locally at the tank.

fuel.jpg.6e21e75e712bda65f75f879033b8f784.jpg

I then took millivolt readings at empty and full and use these to programme the custom sensor. On the newer fw tank it was 30mv empty and 300mv full.  Set the interval rate to 32 seconds and it now reads accurately and damps out the sloshes. 

Using the leds as warning lights.

I only tried this earlier after David mentioned it and confirmed you could input 12v into the analogue inputs. Pretty straightforward. I wired directly from the dash warning feeds for the indicators into analogue 3 and 4. Then in racestudio set the alarm led to come on when the voltage is over 1000mv and set to continuous  (so it flashes in sync with the indicators).

At first I had set the voltage to be over 100mv but this must have been too low as both indicator lights would come on at the same time with either left or right on.

That's my limited knowledge for now! Only other thing I've noticed is I've had to send the configuration through a couple of times on occasion before it's gone in properly.

  • Like 2

Share this post


Link to post
Share on other sites
Steve (sdh2903)

I know Chris is having a look at the display options but if someone figures it out id like to tweak the display

20170308_163301.jpg

In the above pic id like a small rpm reading in the box where the gear indicator would be and a larger speedo readout.

Share this post


Link to post
Share on other sites
Chris King - Webmaster

Yes will be looking at this very soon. 

It involves tweaking the xml files that racestudio loads in. 

I have already got it to display larger rpm and smaller revs but the positioning was a bit off. 

Unfortunately my laptop pc is foobar'd and racestudio won't run on my mac laptop!

 I will probably buy a cheap laptop to solve this issue. 

  • Like 1

Share this post


Link to post
Share on other sites
David_Thame

Nice one chaps. How did you get rid of the lap counter on that screen? its driving me nuts.

Share this post


Link to post
Share on other sites
Chris King - Webmaster

Try this config Steve and let me know if it works OK?

Screen Shot 2017-03-12 at 23.38.33.png

Just did the gear indicator in a different colour as a test - can change

  • Like 1

Share this post


Link to post
Share on other sites
David_Thame

lol....ignore me, rule 1: dont try and configure your dash after your second Gin and Tonic of the evening! Lap thingy was embarrassingly easy...:getmecoat:

Share this post


Link to post
Share on other sites
David_Thame

Actually....i do end up with an empty box in this screen and cant seem to get anything in there that isnt lap related. Can you display another data channel in this blank space?

Capture.PNG

Share this post


Link to post
Share on other sites
Steve (sdh2903)
17 hours ago, Chris King - Webmaster and Joint North East AO said:

Try this config Steve and let me know if it works OK?

Screen Shot 2017-03-12 at 23.38.33.png

Just did the gear indicator in a different colour as a test - can change

Cheers Chris I shall have a play this week.

Share this post


Link to post
Share on other sites
Chris King - Webmaster

Not got mine wired in yet!

will play with a few more config files tonight with luck 

Share this post


Link to post
Share on other sites
Chris King - Webmaster
57 minutes ago, David_Thame said:

Actually....i do end up with an empty box in this screen and cant seem to get anything in there that isnt lap related. Can you display another data channel in this blank space?

Capture.PNG

I'll add it to my list :t-up:

Share this post


Link to post
Share on other sites
Steve (sdh2903)

Chris, what are you using to modify the configuration? Is it something a non-computer genius could attempt?

Share this post


Link to post
Share on other sites
Chris King - Webmaster

Just a text editor. 

The config files are XML and as a web developer I understand that. 

It is a little fiddly and took a fair bit of trial and error but nothing stopping you from having a go. 

I reckon I can easily change background images, colours, item position and size. 

Changing the animated rev counter might be more effort though!

Share this post


Link to post
Share on other sites
Steve (sdh2903)

Chris do you reckon it would be possible to remove the gear indicator box altogether or is that a step too far?

If not could the small revs readout be put in there and the speed made even bigger and centralised. Sort of where the grey line is at present?

If its a pain then no worries. I've had a look at editing xml and it's way out of my comfort zone although I am going to persist and give it a bash

Share this post


Link to post
Share on other sites
Chris King - Webmaster

I'm working on a few layouts so one with no indicator will be on the cards. 

Have been creating backgrounds too but will need to get mine wired up to see if they upload ok. 

Getting my ECU loom tomorrow so will hopefully have it all wired up soon!

Share this post


Link to post
Share on other sites
Chris King - Webmaster

Steve, when you upload a layout to the dash, does it just show the one's you have modified in RaceStudio - or do you get the 'default' set uploaded as well?

Just trying to figure out which of my config mods get sent to the dash.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please review our Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.