Jump to content

Search the Community

Showing results for tags 'starter motor'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Blogs

  • Alexander72's Blog
  • SteveD's Blog
  • Norman's Blog
  • Soot1e's Blog
  • Dommo's Blog
  • KugaWestie's Blog
  • R7 WSC's Blog
  • shindha's Blog
  • Nothing ventured nothing gained
  • Mark's First Time Build Blog
  • marcusb's Blog
  • Meakin's Blog
  • pickmaster's Blog engine swap
  • Steve_Farrimond's Blog
  • PaulJones148's Blog
  • paul gibney's Blog
  • Koso Digital Dash Fitting
  • IanG1's Blog
  • Tel's Tales
  • chrisando's Blog
  • Pistol Pete - Essex AO x 0.5's Blog
  • Enclosed Trailer Build Diary
  • Piece of cake
  • harry may 11's Blog
  • johngill's Blog
  • waynezilla's Blog
  • Julian's 7se rebuild
  • japltor60's Blog
  • Xflow17's Blog
  • How to Assemble a Duratec
  • Beez's 2014 Sprint Blog
  • czphillips' Sigma Swap
  • Speed Series Results
  • Wagoneer's Blog
  • First Westi
  • Quinten's Mighty Blog
  • Chriscooper1's Blog
  • Murraymint's Blog
  • johnev's Blog
  • Master Thatcher's Blog
  • Chris Hooper's SDV Mazda build.
  • Marto's Blog
  • Mr T's Blog
  • Nosbod's Mega S2000 Blog
  • stephenh's Blog
  • TREVORGIDLOW's Blog
  • AdamR's MX-R1000 Build
  • My Lawnmower Runs on Super...
  • John's Sport 250 Build
  • Jaguar C Type
  • Andy665's SEiGHT
  • johnev's Blog
  • Loton Park 2017
  • Toys4x4boys Westy Journey
  • Sprinting (not the Usain Bolt type)
  • Rob
  • A Seven Tour(s)
  • Bills Birthday
  • Raising the dead
  • Gerry
  • Onliest Music - alternative Smeg selections
  • Barney the Mid-Life Crisis

Forums

  • Main Club Area
    • The Start Line
    • Frequently Asked Questions (FAQs)
    • Tech Talk
    • IVA Info
    • X-Cars
  • Out & About With Your Westfield
    • Local Area Meets, Events & Kit Car Shows
    • Speed Series / Hill Climbing / Racing
    • Track Days
    • Places to Visit and Road Trips
  • Club Member Adverts
    • Cars for Sale
    • Cars Wanted
    • Parts for Sale
    • Parts Wanted
  • Club Sponsors & Trade Members
    • WSCC Sponsors & Traders
  • External and Non-Club Member Adverts
    • External Adverts
  • Chat & General Information
    • Stuff & Nonsense
    • Club Boardroom & Website - Evolution & Issues

Calendars

There are no results to display.

Product Groups

  • WSCC Membership
  • WSCC Speed Series
  • WSCC Track Days
  • Admin Only (Archive)
    • Previous Speed Series Events
    • Previous Track Days
    • Previous Merchandise
    • Previous Club Publications
  • Club Publications

Marker Groups

  • Local Area Meeting Locations
  • National Club Event Locations
  • Speed Series Event Locations

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 5 results

  1. sukhyduggal

    Replacement Starter Motor required

    Please can someone help me. I need a replacement starter motor for my Westfield with Ford Mexico engine. What is the easiest way of identifying which one I need and how available might these be? Thanks
  2. JStar

    Starter motor housing

    Hi all Tried starting the Westfield today and it didn't sound right. Took the starter motor off and it was because the domed part of the housing (see photos) had sheared off. Is it possible to buy a new housing on its own, and fix the existing motor, etc, to it or does the whole thing need replacing? I've been searching online and have had no luck. Thanks in advance for any advice
  3. Tim Essex

    Ignition issue

    Hi all. Can anyone help me understand what is starting to fail. When starting in ignition position 3 sometimes I just get a click no engine turnover. Back to 1 then back again and sometimes it starts and sometimes the same. Seems to becoming more frequent. Starter motor starting to fail??
  4. Hello All, I know this has been asked before but I just want to clarifiy I have a black top 2L Zetec with an MT75 Cable clutch gearbox. The starter is on the exhaust side and I'm struggling to get the car to start mostly when hot but now increasingly when cold as well. Strangely it does tend to start on jump leads from another car or from a jump start battery pack though I have a fairly new Odyssey Racing 25 battery in the passenger foot well and this seems to show ok voltage on my shift-I lights So... I'm in two minds whether to find a suitable standard Starter and give that a go, in this case I would need to find a part number as I'm sure it was an LR707 ? but if so I can't seem to find these anywhere? Get an uprated geared starter like a Brise Test a new battery, or replace all the new battery cable I put in when I installed the Odyssey battery with proper ones made to order (unless anyone out there can make battery cables and I can buy them from you?) My thoughts were to test the cheapest things like the cables first, then the starter for a standard starter then make a call on the battery or Brise starter after that Any ideas or help identifying the standard starter? Many thanks Kevn
  5. Westford

    Starter motor heat soak

    As a few of you may be aware I have just got my westie through IVA and registration and I'm having a blast! The engine is in quite a high state of tune so probably pumps out more heat than most, but even though I do have the lower sections of the headers lagged, I still have a small problem with heatsoak often suffered on Zetec installs. I have done the usual searches and reading and have found many bits of advice, but I was wondering who here has had this problem and how did they cure it? Many thanks in advance, Westford
×
×
  • Create New...

Important Information

Please review our Terms of Use, Guidelines and Privacy Policy. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.